The Original CZ Forum

GENERAL => CZ Gunsmithing => Topic started by: dirkdiggler on January 12, 2019, 09:14:47 AM

Title: Issues with Decocker Reassembly ----P01
Post by: dirkdiggler on January 12, 2019, 09:14:47 AM
I've full kits on both BD and Omega decockers without any issues but my P01 is giving me hell. When I'm driving the slave pin out from left to right the lifter spring is getting knocked of position...the last 7 times I've tried.

Any secret "black magic" you guys can share would be great.
Title: Re: Issues with Decocker Reassembly ----P01
Post by: cntrydawwwg on January 12, 2019, 11:48:56 AM
Never ?drive out? the slave pin. You should be able to ?push? it out. You may have to tweak the cage a little to work the pin thru.
Title: Re: Issues with Decocker Reassembly ----P01
Post by: dirkdiggler on January 12, 2019, 12:38:42 PM
Yeah poor choice of words. I have been pressing it in and out with my thumb.... vocabulary becomes limited when the blood pressure is off the charts. Finally figured it out. The slave pin that I made had a slight burr that was probably catching the spring. Another stress inducing project completely self inflicted.

Title: Re: Issues with Decocker Reassembly ----P01
Post by: cntrydawwwg on January 12, 2019, 02:19:45 PM
Gotcha glad you got it. They can be ah,er, difficult at times to say the least.
Title: Re: Issues with Decocker Reassembly ----P01
Post by: Chuck James on January 13, 2019, 10:59:14 AM
Yeah poor choice of words. I have been pressing it in and out with my thumb.... vocabulary becomes limited when the blood pressure is off the charts. Finally figured it out. The slave pin that I made had a slight burr that was probably catching the spring. Another stress inducing project completely self inflicted.

I hate working on something only to find out the problems I'm having were self induced.   ;) ;)

Glad to see you worked it out.  :)