Author Topic: SP01 Tactical Decock Issue  (Read 495 times)

0 Members and 1 Guest are viewing this topic.

Offline dbarn

  • Full Member
  • ***
  • Posts: 339
SP01 Tactical Decock Issue
« on: January 14, 2019, 08:04:09 AM »
Got about 7000 rounds through this one and noticed my de-cock lever is not returning back to it's upward position. The lever is fine. It appears some type of a spring is broken inside the sear cage that does not allow it to fully return. It's still functional just annoying that the lever is somewhat limp. Fixes? If the sear cage has to be tore down, may just leave as is. Thanks!

It appears the problem may be the decock lever spring. Not sure if it's broken or leg of spring has slipped off of decock lever and will require disassembly. Once sear cage is disassembled, should be a $2.00 fix hopefully.
« Last Edit: January 14, 2019, 03:11:36 PM by dbarn »

Offline Tok36

  • Hero Member
  • *****
  • Posts: 4367
Re: SP01 Tactical Decock Issue
« Reply #1 on: January 14, 2019, 03:39:05 PM »
Sounds about right to me. Let us know what you find in there. In case you are not aware, a slave pin is a very helpful tool to have when disassembling/reassembling the decocker sear cage. You can get one form CGW or you can make one out of a similar diameter material.
Will work for CZ pics! (including but not limited to all CZ clones)

Offline dbarn

  • Full Member
  • ***
  • Posts: 339
Re: SP01 Tactical Decock Issue
« Reply #2 on: January 14, 2019, 09:28:28 PM »
Sounds about right to me. Let us know what you find in there. In case you are not aware, a slave pin is a very helpful tool to have when disassembling/reassembling the decocker sear cage. You can get one form CGW or you can make one out of a similar diameter material.

May be a few days. Good thing is the pistol is still functional. Thanks!

Offline dbarn

  • Full Member
  • ***
  • Posts: 339
Re: SP01 Tactical Decock Issue
« Reply #3 on: January 15, 2019, 03:59:43 PM »
Here's a youtube with what I'm experiencing. No way a slam on CZ as parts break after 7000 rounds I'm sure. Just in case someone else experiences this. Have a new spring and slave pin on the way.


Offline Tok36

  • Hero Member
  • *****
  • Posts: 4367
Re: SP01 Tactical Decock Issue
« Reply #4 on: January 15, 2019, 06:20:05 PM »
What is the point of the video, seams like you already had things figured out?
« Last Edit: January 15, 2019, 06:25:36 PM by Tok36 »
Will work for CZ pics! (including but not limited to all CZ clones)

Offline dbarn

  • Full Member
  • ***
  • Posts: 339
Re: SP01 Tactical Decock Issue
« Reply #5 on: January 16, 2019, 07:54:54 AM »
 A picture is worth a thousand words. Having never tore down/reassembled a decocker sear cage if someone told me it's your decocker lever spring, would not have known what the heck they're talking about.

Thought it may be helpful to others??


ETA: The video is not mine, but helped me to determine what the problem is. In fact it was the only video I could locate on this specific issue.
« Last Edit: January 18, 2019, 09:48:24 AM by dbarn »

Offline tdogg

  • Hero Member
  • *****
  • Posts: 1353
Re: SP01 Tactical Decock Issue
« Reply #6 on: January 16, 2019, 04:33:59 PM »
Here is my video showing you how to reassemble the cage:



Hope this helps!

Cheers,
Toby

Offline dbarn

  • Full Member
  • ***
  • Posts: 339
Re: SP01 Tactical Decock Issue
« Reply #7 on: January 16, 2019, 08:25:19 PM »
Outstanding! Thanks very much.  8)

Offline dbarn

  • Full Member
  • ***
  • Posts: 339
Re: SP01 Tactical Decock Issue
« Reply #8 on: January 18, 2019, 05:54:40 PM »
Got it! The CGW slave pin is a must. Below is a photo of the failed spring and the new one installed with the dog leg portion of the spring seated on the decock lever. Thanks for the help!