Author Topic: Bolt not locking back on the last round  (Read 1737 times)

0 Members and 1 Guest are viewing this topic.

Offline Trooper894

  • Jr. Member
  • **
  • Posts: 45
Re: Bolt not locking back on the last round
« Reply #15 on: November 19, 2019, 07:44:55 PM »
It may be the way the light is hitting the edges/corners of the bolt, but to me it looks like someone took a file, then a stone to the corners of the bolt for whatever reason. The rounding of the corners does not appear to be even all the way across, like it was filed/stoned free hand. Perhaps someone thought it might facilitate removal of the bolt receiver for cleaning.
Just a further note. I have a 2018 produced bolt in a pistol and the corners are completely squared off. The bolt in my 2019 produced Micro has squared off corners also.

Offline Henny

  • Newbie
  • *
  • Posts: 5
Re: Bolt not locking back on the last round
« Reply #16 on: November 20, 2019, 08:54:31 AM »
I haven’t called cz yet only because I don’t have anything to compare it to as far as how high other evos’ bolt catch go when the mags are empty compare to mine.  Using magpul, the bolt catch go as high as it can and the bolt locks back.  Using used factory and manticore mags, the bolt catch doesn’t go high enough.  I appreciate all the replies though.


Here you go!  Something to compare yours to!

My bolt:



Magazine catch with CZ 30 round magazine.



Magazine catch with AK magazine.




Hmm, in not sure why I can’t post photos?  Yes, I’m using the image tag?  Do I have to have a certain number of posts?


Here’s the links for them.

https://imgur.com/QcoWpo4

https://imgur.com/fwkWlru

https://imgur.com/K9xRFFJ





Offline SilverBullet76

  • Newbie
  • *
  • Posts: 19
Re: Bolt not locking back on the last round
« Reply #17 on: November 20, 2019, 11:51:16 AM »
Thanks guys for the replies.  Henny, the pictures have been very helpful.  I will contact cz.  There obviously is something wrong with my evo.

As for posting pictures.  I had trouble doing it myself.  I couldn’t do it with mobile devices so I switched to desktop.  Go to your imgur accnt.  Hover your mouse to your accnt and you should see a selection of drop down and click images.  Clink on the picture you wanna post.  Hit copy next to “direct link.”  You can now paste the copied link here, highlight the link and click the mona lisa icon above the emojis, click post and you’re done. 

Offline eastman

  • Hero Member
  • *****
  • Posts: 2617
Re: Bolt not locking back on the last round
« Reply #18 on: November 20, 2019, 08:49:24 PM »
the img tags didn't specify the .jpg image, so it tried to reference the page with the same name. Sized them for display to 900 wide

I haven’t called cz yet only because I don’t have anything to compare it to as far as how high other evos’ bolt catch go when the mags are empty compare to mine.  Using magpul, the bolt catch go as high as it can and the bolt locks back.  Using used factory and manticore mags, the bolt catch doesn’t go high enough.  I appreciate all the replies though.


Here you go!  Something to compare yours to!

My bolt:



Magazine catch with CZ 30 round magazine.



Magazine catch with AK magazine.




Hmm, in not sure why I can’t post photos?  Yes, I’m using the image tag?  Do I have to have a certain number of posts?


Here’s the links for them.

https://imgur.com/QcoWpo4

https://imgur.com/fwkWlru

https://imgur.com/K9xRFFJ
I don't look like my avatar!

Offline SilverBullet76

  • Newbie
  • *
  • Posts: 19
Re: Bolt not locking back on the last round
« Reply #19 on: November 21, 2019, 03:13:41 PM »
Thanks eastman!

Offline boss281

  • Full Member
  • ***
  • Posts: 279
Re: Bolt not locking back on the last round
« Reply #20 on: November 29, 2019, 06:52:29 PM »
Glad I saw this thread. I have a brand new Scorpion pistol and put about 200 rds 115g Speer Lawman through factory 20 and 30 round magazines and the bolt has NEVER locked back. Interesting...
Scorpion Evo S1 Carbine and Pistol, 75BD, SP-01 Tactical CGW Pro Kit, P-01 CGW Defensive Carry Kit, P-07, P-09

Offline SilverBullet76

  • Newbie
  • *
  • Posts: 19
Re: Bolt not locking back on the last round
« Reply #21 on: December 01, 2019, 01:06:39 PM »
What model do you have and when did you purchase yours?  Right now my scorpion is at cz.  Hope it gets fixed.  I also noticed excessive wear on the hammer.  Their email said 4-6 weeks turnaround. 

Offline boss281

  • Full Member
  • ***
  • Posts: 279
Re: Bolt not locking back on the last round
« Reply #22 on: December 01, 2019, 01:37:59 PM »
Glad I saw this thread. I have a brand new Scorpion pistol and put about 200 rds 115g Speer Lawman through factory 20 and 30 round magazines and the bolt has NEVER locked back. Interesting...

Update: I was very surprised to see how fouled the gun after 4 boxes of ammo, so I field stripped it and cleaned it really good (I did a basic clean and lube when I first received it as well.

Since I had updated the trigger, trigger springs, right side safety and magazine release, I took those all apart as well, cleaned and lightly lubed moving metal parts where applicable.

Upon reassembly and light lube, the bolt is holding back properly.  Must have not quite put something back together properly although the pistol shot fine other than the bolt hold back issue. Put an inexpensive Holosun red dot on it, cowitnessed with the fixed sights. Happy now, will see how it performs at a Level 1 Steel Challenge match. 
Scorpion Evo S1 Carbine and Pistol, 75BD, SP-01 Tactical CGW Pro Kit, P-01 CGW Defensive Carry Kit, P-07, P-09

Offline SilverBullet76

  • Newbie
  • *
  • Posts: 19
Re: Bolt not locking back on the last round
« Reply #23 on: December 01, 2019, 03:07:07 PM »
Glad I saw this thread. I have a brand new Scorpion pistol and put about 200 rds 115g Speer Lawman through factory 20 and 30 round magazines and the bolt has NEVER locked back. Interesting...

Update: I was very surprised to see how fouled the gun after 4 boxes of ammo, so I field stripped it and cleaned it really good (I did a basic clean and lube when I first received it as well.

Since I had updated the trigger, trigger springs, right side safety and magazine release, I took those all apart as well, cleaned and lightly lubed moving metal parts where applicable.

Upon reassembly and light lube, the bolt is holding back properly.  Must have not quite put something back together properly although the pistol shot fine other than the bolt hold back issue. Put an inexpensive Holosun red dot on it, cowitnessed with the fixed sights. Happy now, will see how it performs at a Level 1 Steel Challenge match.
That’s good!  Mine would lock back, using the factory mag, if I racked and slowly release the charging handle, but when I do the HK slap or shoot it, I could not get the bolt to lock back.  Anyway, 1 week has passed and I only have 3-5 more weeks to get it back.  Can’t wait.   

Offline SilverBullet76

  • Newbie
  • *
  • Posts: 19
Re: Bolt not locking back on the last round
« Reply #24 on: January 07, 2020, 05:25:23 PM »
Update.  I just received an email saying it’s been repaired.  Not sure how adjusting the breech face would fix the bolt not locking back.  Below is what they emailed me.

Description: bolt not locking back

Work Performed: Adjusted breech face lead in test fired good.

Offline SilverBullet76

  • Newbie
  • *
  • Posts: 19
Re: Bolt not locking back on the last round
« Reply #25 on: January 15, 2020, 04:55:32 PM »
Just received the evo and the bolt locks back when I rack and release it majually.  I haven’t shot it yet, but see no reason why it wouldn’t lock back.  Thanks guys for all your input.