Author Topic: Please help !  (Read 251 times)

0 Members and 1 Guest are viewing this topic.

Offline Hillbilly83

  • Newbie
  • *
  • Posts: 4
Please help !
« on: January 21, 2020, 05:05:22 PM »
Hi new memeber here I am a proud new owner of a cz p10c as of December 30 of last year ... the gun shoots great easy to clean and love the trigger but I have one issue and I hope y’all can help . I took it out of box and apart wipped excess oil off and lubed the pistol afterwards I noticed that the slide lock works perfect when a magazine is in the pistol . When a magazine is out however the slide lock works on the right side always but on the left side of pistol it only works some times ... in fact if I take pressure off it immediately goes forward I’m at a loss please help thanks

Offline jurek

  • Sr. Member
  • ****
  • Posts: 507
Re: Please help !
« Reply #1 on: January 21, 2020, 11:08:20 PM »
Use "search" on the upper right corner. There is over 10 threads regarding this issue. Hopefully you will find your answer.

Offline Hillbilly83

  • Newbie
  • *
  • Posts: 4
Re: Please help !
« Reply #2 on: January 22, 2020, 11:33:31 AM »
Thanks I’ll try looking though posts it really does not affect the pistol but it bothers me I talked to cz they said they had never heard of that before and I could send it in .

Offline Togmaster

  • Full Member
  • ***
  • Posts: 138
Re: Please help !
« Reply #3 on: January 22, 2020, 12:19:23 PM »
I never heard of this problem either. Take the advice of the manufacturer and send it in.