Author Topic: Rami w/decocker new "feature"  (Read 648 times)

0 Members and 1 Guest are viewing this topic.

Offline wight@yahoo

  • Newbie
  • *
  • Posts: 4
Rami w/decocker new "feature"
« on: January 25, 2020, 01:05:49 PM »
I installed the CGW old style trigger in my new Rami.  Now when the hammer is fully down double action will not engage, the trigger does nothing.  It pulls like it should, but it doesn't move the hammer. Now, if I pull the hammer back very slightly, 1/32", I hear a click and it works like it should.  All other functions are normal.  I really don't care about this anomaly because anytime I rack the slide to put one in the tube full cock and half cock work just fine.

Should I persue this or let it go?

Offline Tok36

  • Hero Member
  • *****
  • Posts: 5088
Re: Rami w/decocker new "feature"
« Reply #1 on: January 25, 2020, 05:22:25 PM »
If you have the Double Action pre-travel set scerw located in the top of the trigger installed remove it and see if that remedies the issue. If you do not have the CGW Reach Reduction Kit installed the upper set scerw is not required.

To me it sounds like the trigger is not making it far enough forward to achieve Double Action reset.
Will work for CZ pics! (including but not limited to all CZ clones)

Offline rckendall

  • Jr. Member
  • **
  • Posts: 99
Re: Rami w/decocker new "feature"
« Reply #2 on: January 25, 2020, 05:37:16 PM »
I had the same issue with my P-01 and PCR when I installed the old style triggers. I guess there was a batch of triggers that did not get machined quite enough in the area of the top set screw. CGW sent me new triggers with a stamped self addressed envelope for the return triggers. They also sent an instruction sheet as how to install the trigger without complete disassembly.

The problem went away immediately. Thanks to CGW and their attention to customer service.

Richard