Author Topic: A01 short reset kit issues  (Read 928 times)

0 Members and 1 Guest are viewing this topic.

Offline farmer10

  • Jr. Member
  • **
  • Posts: 31
A01 short reset kit issues
« on: June 24, 2022, 11:32:01 PM »
I just installed the flat trigger short reset kit into my a01 which functioned 100% before.
(Disconnector, flat trigger,trigger spring)  also the extended firing pin and spring, 10lb hammer spring.
The pistol works fine in Da/SA with the slide off. Put the slide on and hammer will not drop to fire. I take the slide off, barely push up on the sear where it meets the hammer, and the hammer comes forward. I don’t understand why it functions fine without the slide but not with the slide? Could it be the trigger bar springs? I would call CZC but it’s the weekend and I’ve called 3 times this past week leaving a voicemail with no return call back. If anyone has a recommendation it would be appreciated. Thanks

Offline farmer10

  • Jr. Member
  • **
  • Posts: 31
Re: A01 short reset kit issues
« Reply #1 on: June 24, 2022, 11:48:01 PM »
After tinkering with it more I can get the sear to reset with the slide on as well by barely pushing up from underneath it with a screwdriver. Once I rack the slide I get the same problem again until I push the sear.
« Last Edit: June 25, 2022, 02:00:03 AM by farmer10 »

Offline SoCal

  • Sr. Member
  • ****
  • Posts: 518
Re: A01 short reset kit issues
« Reply #2 on: June 26, 2022, 02:06:54 PM »
Disconnector my need some fitting or ???  Try emailing on Monday.  Others may chime in with more info.

Is this in DA mode...SA...or both SA/DA?  If you push on the hammer with the trigger pulled does the hammer drop?  Over travel screws backed out?
If I had known how much better being retired is than working I would have done it FIRST.

Offline farmer10

  • Jr. Member
  • **
  • Posts: 31
Re: A01 short reset kit issues
« Reply #3 on: June 26, 2022, 04:24:27 PM »
I’ll give them a call tomorrow. The straight trigger doesn’t have any set screws. I use the same trigger on my P07,p09, P01, shadow 2 as well never had any problems with them. With the slide off the gun fires fine in Da and Sa. With the slide on it will not drop in either unless I push the sear off the hammer hook with a screwdriver. Even with the trigger held pushing on the hammer doesn’t help. I figured it has to do with the disconnector. All my other guns have pro kits I’ve installed and polished myself and have always had no problems with disconnectors. I’m going to swap the factory trigger in to rule that out.

Offline Earl Keese

  • Hero Member
  • *****
  • Posts: 5045
Re: A01 short reset kit issues
« Reply #4 on: June 26, 2022, 04:54:32 PM »
I'm with Socal. Disco most likely needs a little fitting.

Offline farmer10

  • Jr. Member
  • **
  • Posts: 31
Re: A01 short reset kit issues
« Reply #5 on: July 02, 2022, 01:53:18 AM »
Disco did need fitting. Cz customs helped me figure it out thank you all